IBrowse Home   News   Store   Download   Known Issues   Add-ons   Search Engines   FAQ   Mailing Lists   Documentation
Development Radar: 612 issues open (30 assigned) and 1025 blown away
Did you know... IBrowse's JavaScript core implementation closely adheres to the JavaScript 1.6 and ECMAScript (edition 3) standards?
News
23 Oct 2019>IBrowse 2.5.1 Released

IBrowse 2.5.1 is now available for download (OS4 users can also upgrade using AmiUpdate). This marks the first free update for registered users of IBrowse 2.5. IBrowse 2.4 and 1.x users can upgrade to IBrowse 2.5.1 via our store at special discounted rates.

We hope to have addressed most of the issues reported since the release of IBrowse 2.5 almost 8 weeks ago:

  • Updated Danish, Spanish and Swedish catalogs, by Niels Bache, Javier de las Rivas and Pär Boberg respectively
  • Localised missing strings in spoofing preferences
  • Fixed corruption in built-in MSIE User-Agent strings
  • Tweaked the installer to make 2.5.x upgrades nicer
  • The F5 key can now be used to reload a page
  • JS: MorphOS native javascript.library available again
  • 68k: Handle datatypes that expand 8-bit + transparent colour images to 32-bit RGBA (fixes our 256 colour icons having non-transparent magenta backgrounds in MorphOS)
  • 68k: Full alpha channel support enabled for systems using CyberGraphX V51 or higher (MorphOS)
  • OS4: Enabled 2.5 updates via AmiUpdate (exit IBrowse before performing any updates)
  • Changed the default JPEG decoder swap memory limit from 1Mb to unlimited on OS4 and MorphOS
  • Fixed NOTRANSPARENT tooltype being ignored for GUI images
  • Fixed broken HTTPS proxy functionality, where incorrect hostname was used for SNI
  • Fixed broken MUI 4/5 detection that was causing problems in TextEditField and preventing context-sensitive mouse points from working with MUI 3.x
  • Added some workarounds in the install script so that it doesn't error with the MorphOS installer
  • 68k: Now works again on Workbench 3.0, after incorrect requirement for keymaps.library V39 (Kickstart 3.0 has V37)
  • 68k: Fixed crashes when external modules (e.g. codecs and protocols) fail to load for any reason
One issue that we are still working on is AmiSSL v4 crashing on 68020 and 68030 systems that don't have a FPU. We hope for this to be fixed in AmiSSL 4.4, but we currently do not possess the capability to build the 68K version of AmiSSL v4, so we are waiting on the AmiSSL Open Source Team to rectify the problem. Due to API changes, AmiSSL 4.4 will not work with IBrowse 2.5 until we release a new update to support it, which we will do when AmiSSL 4.4 has been released :-). We shall also be looking into AmiSSL v4 performance on 68K systems to see if any optimisation is possible to improve browsing performance.

show all news...
IBrowse is © 2001-2019 Stefan Burstrom, © 1995-2001 Omnipresence Intl. All rights reserved.
[counter]